寒 风 发布于 2015-12-08 22:36  阅读 1104 次
今天同事拉了新项目代码。编译的时候直接抛异常,提示实体类没有应用命名空间。跑去看了一下,原来是 WCF 服务配置的问题。同事的操作步骤是:添加服务引用 -> 输入 WCF 服务地址 -> 修改命名空间 -> 点击“确定”按钮。在业务代码中,并没有引用实体类项目 dll 的命名空间,只引用了添加好的 WCF 服务命名空间。于是发生了上述问题。为了保证 WCF 服务实体类与前端项目实体类的一致性,所以以往的项目一般都是直接使用 WCF 服务 ... ...
寒 风 发布于 2015-10-04 20:51  阅读 902 次
由于某些在线编辑器不支持 Windows 8.1 自带的“微软拼音”输入法,导致在使用“微软拼音”输入法时需要额外安装其他拼音输入法。但是在安装了其他输入法后,“微软拼音”这个狗皮膏药又没办法删除~~~实在是可恨!!!为什么会出现这种情况呢?因为本人之前的操作是这样的:安装操作系统 -> 打开控制面板 -> 语言 -> 添加语言 -> 选择“中文(中华人民共和国)”中的输入法“微软拼音” -> 然后再安装其他拼音输入法。完了后,回头再操 ... ...
寒 风 发布于 2015-06-16 16:00  阅读 1766 次
刚才部署了新系统基础版本到测试服务器上给测试组同事测试。在调用 WCF 服务时,返回异常信息:“服务器已拒绝客户端凭据”。服务是采用 net.tcp 方式调用,服务端的 bindings 没有设置 security mode 配置。WCF 的 netTcpBinding、netNamedPipeBinding 和 netMsmqBinding 在不设置 security mode 时,会默认使用 Transport 模式。只有 basi ... ...
寒 风 发布于 2015-04-25 11:36  阅读 1497 次
昨晚把博客迁到了新的服务器上,对新服务器环境重新做了配置。万事俱备后,访问博客地址,浏览器提示访问出错。检查了后台,错误提示如下:TypeError: 'NoneType' object has no attribute '__getitem__'对本地的环境进行了测试,却是一切正常。从错误提示来看,应该是从 MongoDB 读取数据出错了。遂在服务器上写码调试,发现是 pymongo 的问题,找不到 Connection 类了。对比了 ... ...
寒 风 发布于 2015-04-19 10:51  阅读 1896 次
昨天晚上在家调试项目代码,编译好后,在用户登录时抛异常了。看了下日志,异常内容如下:System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://localhost:8888/LogService. The connection attempt lasted for a time span of 00:00:02.0592036. TCP er ... ...
寒 风 发布于 2015-04-09 09:38  阅读 1774 次
调试 WCF 服务时,一直报异常:无法识别该 URI 前缀。元数据包含无法解析的引用:“net.tcp://localhost:8888/LogService”。套接字连接已中止。这可能是由于处理消息时出错或远程主机超过接收超时或者潜在的网络资源问题导致的。本地套接字超时是“00:05:00”。远程主机强迫关闭了一个现有的连接。如果该服务已在当前解决方案中定义,请尝试生成该解决方案,然后再次添加服务引用。检查了服务器端的 endpoin ... ...
寒 风 发布于 2015-01-28 22:22  阅读 1663 次
今天给同事开了个 TFS(Team Foundation Server 2012) 帐号,用于管理他自己负责的项目。在用该帐号创建团队项目时,出现错误:TF218027: 在运行 SQL Server Reporting Services 的服务器上,未能创建以下报表文件夹: /TfsReports/xxx。报表服务器位于: http://Server/Reports。错误为: 为用户“Server\fang”授予的权限不足,无法执行此 ... ...
寒 风 发布于 2015-01-19 21:16  阅读 1063 次
今天在调用一个 WCF 服务时,抛了以下异常:An error occurred while receiving the HTTP response to http://localhost:9999/Base.svc. This could be due to the service endpoint binding not using the HTTP protocol. This could also be due to an HT ... ...
寒 风 发布于 2015-01-19 20:49  阅读 1287 次
今天在 MVC 4 Web 项目中引用 WCF 服务,添加服务引用成功。调用 WCF 服务后,编译项目,出现以下错误信息:自定义工具错误: 无法生成服务引用“Service.Base”的代码。  请检查其他错误和警告信息,了解详细信息。搜了一下,在园子里发现了这么一个问答:wcf服务引用,控制台项目和web项目两个引用wcf服务有区别吗? 在这个问答下找到了解决办法,详细可以参考这个链接说明:Add service reference ... ...
寒 风 发布于 2014-12-31 10:39  阅读 1401 次
昨天在新机器上安装了 Visual Studio 2013 社区版,装的是 with Update 4 的版本。安装完后,接着安装中文语言包。然后报错提示版本不符。这下好了,继续用英文版吧,反正也没什么。今天因为要装建模项目的模板,瞎折腾了好久没弄成功。然后,发现,英文版突然变成了中文版。后来想了一下,大概是因为这个操作:关闭所有 Visual Studio 实例。在命令提示符中进入到 devenv.exe 所在的目录,在“VS 安装目 ... ...